Captions Search App returns no results found

I downloaded the sample code about caption search from here:
when i tried the function of caption search by using the kaltura service ,it works,but it turns to my service(kaltura CE V5.0.0),it doesn’t work ,my config files is as bellow:

`partnerId =100

adminSecret =81c6254529a654c258818c910c80e8db

entryId =0_x04gh0ks

serviceUrl =http://121.248..

kdpUiconfId =6709458

kClipUiconfId =6709459`

Does anybody know what the problem is?Is anywhere else need to authorize to the user?



CE5 is a very old version and is no longer actively supported.
I suggest you install version 9 following:

Then please let us know should you have additional questions.

Thank you,

Thank you for your reply.Actually,i have installed the Community Edition Kaltura Server 9.19.5,but when i log in as the administrator,then add a publisher,i want to log in the Kaltura Management Console (KMC) by using publishers->publisher management,chose a publisher,click actions->manager,it turns to http:/hostname/index.php/kmc/kmc2,i get confused,why it is kmc2(not kmc4) .The page shows" The requested URL /index.php/kmc/kmc2 was not found on this server."what’s the problem?Thank you!

Lets start by running:
# kaltlog
from the shell while making the requests and, in parallel, run an HTTP sniffer and check the URLs that are being requested. Also run, it does a lot of basic tests and can save time in identifying the issue.

hi,jess! I log in the kaltura ce 9.19.5 by Kaltura Administration Console,but when i log in KMC using publishers->publisher management,the page remains loading…one thing i need to add,i am in china,so does it have to download some files from google server,that the problem i can not get the kmc page resaults.Thank you!


Please edit /opt/kaltura/app/configurations/local.ini:

ga_account =

Should fix the issue,

Hi,jess,i am sorry to disturb you again. I do as you said,but it still doesn’t work.I have no idea,so i install kaltura on a clean centos server(virtual machine),during the installment,no error occurs.but when i log in kaltura,same problem occurs,i can not log in the KMC.
(1)log in KAC ,add a new publisher

(2) log in KMC from “Manager”

it stays on KAC and gives the error “Internal server error occurred”

So i review my installment process,the only place i input “” is here:

CDN hostname [localhost.localdomain]:
Apache virtual hostname [localhost.localdomain]: localhost.localdomain
Vhost port to listen on [80]: 80
DB hostname []:
DB port [3306]:[enter]
MySQL super user [only for install, default root]: root
MySQL super user passwd [only for install]:
 Analytics DB hostname []:[enter]
Analytics DB port [3306]:[enter]
Sphinx hostname []:[enter]
Media Streaming Server host [localhost.localdomain]:[enter]
Secondary Sphinx hostname [leave empty if none]:[enter]
Service URL [http://localhost.localdomain:80]:
Kaltura Admin user (email address):
Admin user login password (must be minimum 8 chars and include at least one of each: upper-case, lower-case, number and a special character):
Confirm passwd:
Your time zone [see], or press enter for [Asia/Shanghai]:[enter]
Your Kaltura install name (this name will show as the From field in emails sent by the system) [Kaltura Video Platform]:[enter]
Your website Contact Us URL []:[enter]
Your ‘Contact us’ phone number [+1 800 871 5224]:[enter]

Any suggestions?Thank you !!