Can't get rid of snakeoil in kaltura apache ssl configuration file when installing

I am new to Kaltura and have limited Linux experience, so please have mercy :confused:

I try to follow the instructions for installing Kaltura on Ubuntu 14.04:

After downloading & installing the packages and providing answers to the questions about CDN hostname etc. an error occurs in the configuration of kaltura-front. Here’s the (hopefully) relevant part of the output:

Setting up kaltura-front (10.18.0-1+b1) …
Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Module socache_shmcb already enabled
Module ssl already enabled
@@@@@@@2/etc/ssl/private/ssl-cert-snakeoil.key@@@@@@@@@@@2
Site zzzkaltura.ssl disabled.
To activate the new configuration, you need to run:
service apache2 reload
Enabling site zzzkaltura.ssl.
To activate the new configuration, you need to run:
service apache2 reload
Site apps already enabled
Site var already enabled
Site admin already enabled

  • Reloading web server apache2 *
  • The apache2 configtest failed. Not doing anything.
    Output of config test was:
    AH00526: Syntax error on line 21 of /etc/apache2/sites-enabled/zzzkaltura.ssl.conf:
    SSLCACertificateFile: file ‘/etc/apache2/@SSL_CERTIFICATE_CHAIN_FILE@’ does not exist or is empty
    Action ‘configtest’ failed.
    The Apache error log may have more information.
  • Restarting web server apache2 [fail]
  • The apache2 configtest failed.
    Output of config test was:
    AH00526: Syntax error on line 21 of /etc/apache2/sites-enabled/zzzkaltura.ssl.conf:
    SSLCACertificateFile: file ‘/etc/apache2/@SSL_CERTIFICATE_CHAIN_FILE@’ does not exist or is empty
    Action ‘configtest’ failed.
    The Apache error log may have more information.

What I don’t understand is the reference to the snakeoil certificate. I’ve created a “real” certificate including certificate authority file and put them into the zzzkaltura.ssl.conf file (made it a real file in /etc/apache2/sites-available and removed the link to the /opt/kaltura file) but somehow when I re-run the installation the reference to snakeoil remains. Obviously I’m missing something. I’ve also updated the 000-default and corresponding ssl files with the new certificate, because Kaltura seems to use those files as well, but that doesn’t fix it either. I’ve been on and off trying all kinds of work-arounds from various internet forums and pages, removing and re-installing/re-configuring Kaltura many many times over the past 3 weeks or so without making significant progress, so I really would welcome any suggestions/hints - thanks!

Best regards,

  Peter

Hello,

The snakeoil is just the default cert generated by the ssl-cert package postinst script. It is good that you are using an actual, not self signed cert:)
There seem to be a bug in the flow of the SSL configuration of kaltura-front postinst, and I will look into it.

Meanwhile, I suggest you
# dpkg-reconfigure kaltura-front
selecting none SSL config and finish the install.
Then, you can manually edit /opt/kaltura/app/configurations/apache/kaltura.ssl.conf and set values for:
SSLCertificateFile
SSLCertificateKeyFile
SSLCACertificateFile
<VirtualHost @KALTURA_FULL_VIRTUAL_HOST_NAME@>

and:
# a2dissite zzzkaltura.conf
# ln -s /opt/kaltura/app/configurations/apache/kaltura.ssl.conf /etc/apache2/sites-available/zzzkaltura.ssl.conf
# a2ensite kaltura.ssl.conf
# /etc/init.d/apache2 reload

Let me know if you have any issues

Hello,

Fixed.
You should be able to do:
# aptitude update
# aptitude install kaltura-front

and get the latest. version should be: 10.19.0-1+b2

Great! Thank you very much for this help! Unfortunately I’m currently traveling and can’t try this right away, but it will be the first thing I do once I return this evening. Of course I’ll report on the results. Thanks again!

Peter

Surething, Peter. Thanks for reporting it.

Dear Jess,

Thanks a lot, that worked perfectly and got me through the installation without any error messages! WHen accessing my site through https://cwte.eu:80 I do get the Welcome to the Kaltura Video Platform - Community Edition 10.19.0-2 webpage - great!

However, it seems not all is well yet, when I try to access the kaltura server through the webbrowser https://mywebsite:80/admin_console I get a login screen, but when I try to log in with the account details that I entered during the installation I get:
An error occurred (error code: API:-1)

I will look through the forum to see whether I can find a solution for this. Also, I found out that I had not yet installed Flash on this computer so I need to do that as well before I can access kmc and see whether that works.

Anyway I am really, really happy with this progress, I have been stuck at this snakeoil think on and off over the last few weeks over countless re-installation attempts. I’ll report back when I can’t solve the login issue. Thanks a gain for your help with this!

Best regards,

  Peter

P.S.: I used the default port 80 during the installation but now I have an https connection on that port, which is somewhat unusual. I can of course change that in the zzzkaltura.ssl.conf file to the more usual port 443. Would that be enough or do I need to make more changes? Or would it be better to leave this as is?

Dear Jess,

I think I found the answer to my last P.S. already in the FAQ (there is a script to reconfigure the server settings).
As for kaltura propoer: I found that, with all the re-installations & experiments I did, I must have done yet another kaltura-drop-db.sh and this is probably the reason why I can’t log in. I’m trying to reinstall everything now and will let you know.

Hi Peter,

Sure. Do let me know if you have any issues.

Dear Jess,

After trying several suggestions on this forum, the login problem was not solved and the kaltura installation did seem to be somewhat messed up, so I decided to reinstall from scratch. The installation script ran almost flawlessly, except that I got a warning where the script enables the various apache2 modules and sites and wants to reload apache2. It then concludes (incorrectly) that apache2 is not runnng and wants to restart it, resulting in the following output:
Reloading web server apache2

Apache2 is not running
Restarting web server apache2
There are preocesses named 'apache2’running which do not match your pid file which are left untouched in the name of safety, Please review the situation by hand.

The script then concludes that package kaltura-front failed to install and tries to recover, which works out fine this time, including reloading of apache2 and restarting monit.
However, at the very end I get two error messages saying:
/etc/monit/conf.d/batch/rc:3: Warning: Program does not exist: '/etc/init.d/kaltura-batch
/etc/monit/conf.d/batch/rc:4: Warning: Program does not exist: '/etc/init.d/kaltura-batch

When I checked I found that the package kaltura-batch indeed hasn’t been installed, so I manually installed it (apt-get install kaltura-batch) which downloads the package but fails with the following message:

ERROR 1045 (28000): Access denied for user ‘kaltura’@‘localhost’ (using password: YES)

This seemed to me a problem with packages being installed out of order since indeed the kaltura databases and user had not yet been created in MySQL, so I restarted install_kaltura_all_in_1.sh.

However, this results in the same error message

ERROR 1045 (28000): Access denied for user ‘kaltura’@‘localhost’ (using password: YES)

So I ran kaltura-sanity.sh and got mostly OK results except:

  • kaltura-batch deamon is not running
    (but kaltura-batch init status is OK)
  • memcached deamon started by Monit Failed
  • check_testme_page Failed
  • check_kmc_index_page Failed
  • and from thereon many errors about pages, create Partner, etc.

Also, when checking with myphpadmin, the kaltura database tables have not been created (let alone that they would be populated). When I try to start the kaltura-batch deamon manually, I get the following:

Starting:[Failed]
Serice batch isn’t running but stale lock file exists
Removing stale lock file at /opt/kaltura/log/batch/batch.pid
/usr/bin/php … 2>&1 &
[ OK ]

But apparently the deamon isn’t running, because trying to start it again gives the same result and ps -aux doesn’t show any process including ‘kaltura’ in the name.

I can now access the same “Welcome to the Kaltura Video Platform…” webpage as yesterday and still cannot log into the admin_console (which makes sense because the database with the username does not exist).

Obviously I’m doing something very wrong and now I’m stuck again, sorry… Could you please give me a hint on what to try next?

Best regards,

 Peter

Hi Peter,

Indeed, the packages need to be installed in a certain order which why we provide the install_kaltura_all_in_1.sh wrapper.

I would suggest you remove everything using:
# /opt/kaltura/bin/kaltura-drop-db.sh $MYSQL_ROOT_PASSWD && aptitude purge “~Nkaltura” -y && aptitude purge “~Napache2” -y && rm -rf /opt/kaltura
and then re-run:
# ./install_kaltura_all_in_1.sh 2>&1 | tee -a /tmp/kaltura.log

if something fails, please take a look at the /tmp/kaltura.log and share relevant pieces of it here. Please be sure to mask any sensitive info when doing so.

Dear Jess,

Thanks once more for your help. Unfortunately I even run into problems removing Kaltura in this way: he kaltura-drop-db.sh crashes with:
Error at line1: Operation DROP USER failed for ; kaltura’ @’%'
which makes sense because the database was not populated (or even created, for that matter). Therefore, I left out his first section and started the command with aptitude purge “~NKaltura” etc.
This failed with e message
ERROR 1045 (28000): Access denied for user ‘kaltura’@‘localhost’ (using password: YES)

Do I just neglect these errors or should I remove kaltura manually through the package manager (I’ve done that before: just remove anything with kaltura in the name, remove the databases if present, remove the apache2 configuration files for the sites, and delete /opt/kaltura). What is the best approach? After that I can remove apache2 (preferably later this evening when nobody will notice that our regular website is down :wink: ).

Thanks again for your advice!

Best regards,

Peter

Hi Peter,

If you never got to the stage of populating the Kaltura DB, which seems to be the case, then there’s no need to drop it:)
I recommend you experiment on a machine that does not currently run a live site… as you know, the installation makes changes to the Apache config and also needs to reload it several times, better install it on a server that isn’t used for other purposes.

And, of course, if you DO HAVE OTHER APACHE CONFIGURATIONS on this machine, DO NOT purge Apache as it will delete them.

Dear Jess, thanks for your concern. Don’t worry, it’s only my students that use this server ;-). And I already backed up /etc/apache and /etc/ssl. But I don’t have a convenient alternative server that meets the prerequistes and is externally accessible (I’m travelling again) so the students wil have to suffer through this I’m afraid. In the end they are the ones that are going to benefit once everything is working.

I’ll run the removal commands for kaltura and apache a few times and the will use synaptic to remove any remaining packages. I’ll remove /opt/kaltura and the apache config files manually and then start the installation as yo described. once I have the log file I’ll report back.

Best regards,

   Peter

Dear Jess,

I’ve ran the script and everything went well up to the point where the databases had been created. Then an error occurred:
ERROR: Couldn’t make an API request to http://kaltura.cwte.eu:8082/api_v3/index.php?service=system&action=ping.

In the configuration questions, I had indicated that kaltura should listen on port 443 (default SSL), although in the very first installation of kaltura that I did I had indeed answered 8082. I changed that later because I had read on the forum that using non-default ports could create problems during the installation. Apparently, this 8082 is still memorized somewhere and overrides the 443 that I entered during installation. Since apache by default only listens to ports 80 and 443, I can understand that the installation script cannot connect to port 8082 even though that is configured in zzzkaltura.ssl.conf.

Do you have any suggestion where this 8082 setting from the past is memorized and how I can delete it? Then I can remove everything again and run the script once more. Thanks for your help!

Best regards,

 Peter

Hi Peter,

The installation can work on any port actually, you might run into some issues further along though, in particular with the preview and embed. As for the port, if you completely removed the old install as per our previous discussion there should be no left overs.

I suggest:
# apachectl -t -DDUMP_VHOSTS

and also,
# grep 8082 /opt/kaltura/app/configurations/* -r

lets see what we find.

Dear Jess,

Thanks again for your help! As it turns out, the ports.conf still contained a leftover reference to port 8082 (in addition to 80, 8080, 443, and 8443), however the conf files configured apache to only listen on 443 and 8080. So to avoid further problems this time I not only removed /etc/apache2/sites-* but the complete /etc/apache2, removed all kaltura and apache related packages through synaptic to avoid the problems I had before, and re-ran the installation script. This avoided the 8082 problem, so apparently that was indeed caused by the ports.conf, but now there is a problem with a dependency on libapache2-mod-php5. The error message is:

dpkg: error processing package libapache2-mod-php5 (–configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of kaltura-html5lib:
kaltura-html5lib depends on libapache2-mod-php5; however:
Package libapache2-mod-php5 is not configured yet.

dpkg: error processing package kaltura-html5lib (–configure):
dependency problems - leaving unconfigured

When I check with synaptic the status of libapache2-mod-php5 shows green (installed). Should I try and remove/reinstall it manually and then re-run the script? Or is there a better approach? Thanks again for your help!

Best regards,

  Peter

In case I’m overlooking something I’ve included the complete log file (excluding some privacy-sensitive stuff):

–2015-09-15 18:28:46-- http://installrepo.kaltura.org/repo/apt/debian/kaltura-deb.gpg.key
Resolving installrepo.kaltura.org (installrepo.kaltura.org)… 54.230.130.165, 54.230.131.6, 54.230.131.70, …
Connecting to installrepo.kaltura.org (installrepo.kaltura.org)|54.230.130.165|:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 1727 (1,7K) [text/plain]
Saving to: ‘STDOUT’

 0K .                                                     100%  229M=0s

2015-09-15 18:28:46 (229 MB/s) - written to stdout [1727/1727]

OK
/usr/bin/aptitude
Hit http://installrepo.kaltura.org jupiter InRelease
Ign http://ppa.launchpad.net trusty InRelease
Ign http://nl.archive.ubuntu.com trusty InRelease
Ign http://nl.archive.ubuntu.com trusty-updates InRelease
Ign http://extras.ubuntu.com trusty InRelease
Ign http://ppa.launchpad.net trusty InRelease
Ign http://nl.archive.ubuntu.com trusty-backports InRelease
Hit http://nl.archive.ubuntu.com trusty Release.gpg
Ign http://ppa.launchpad.net trusty InRelease
Get: 1 http://nl.archive.ubuntu.com trusty-updates Release.gpg [933 B]
Hit http://extras.ubuntu.com trusty Release.gpg
Hit http://nl.archive.ubuntu.com trusty-backports Release.gpg
Hit http://nl.archive.ubuntu.com trusty Release
Hit http://ppa.launchpad.net trusty Release.gpg
Hit http://extras.ubuntu.com trusty Release
Get: 2 http://nl.archive.ubuntu.com trusty-updates Release [63,5 kB]
Hit http://installrepo.kaltura.org jupiter/main amd64 Packages
Hit http://nl.archive.ubuntu.com trusty-backports Release
Hit http://ppa.launchpad.net trusty Release.gpg
Hit http://ppa.launchpad.net trusty Release.gpg
Hit http://nl.archive.ubuntu.com trusty/main Sources
Hit http://ppa.launchpad.net trusty Release
Hit http://nl.archive.ubuntu.com trusty/restricted Sources
Hit http://extras.ubuntu.com trusty/main Sources
Hit http://nl.archive.ubuntu.com trusty/universe Sources
Hit http://nl.archive.ubuntu.com trusty/multiverse Sources
Hit http://ppa.launchpad.net trusty Release
Hit http://nl.archive.ubuntu.com trusty/main amd64 Packages
Hit http://nl.archive.ubuntu.com trusty/restricted amd64 Packages
Hit http://extras.ubuntu.com trusty/main amd64 Packages
Hit http://ppa.launchpad.net trusty Release
Hit http://nl.archive.ubuntu.com trusty/universe amd64 Packages
Hit http://nl.archive.ubuntu.com trusty/multiverse amd64 Packages
Hit http://extras.ubuntu.com trusty/main i386 Packages
Hit http://nl.archive.ubuntu.com trusty/main i386 Packages
Hit http://ppa.launchpad.net trusty/main amd64 Packages
Hit http://nl.archive.ubuntu.com trusty/restricted i386 Packages
Hit http://ppa.launchpad.net trusty/main i386 Packages
Hit http://ppa.launchpad.net trusty/main Translation-en
Hit http://ppa.launchpad.net trusty/main amd64 Packages
Hit http://ppa.launchpad.net trusty/main i386 Packages
Hit http://nl.archive.ubuntu.com trusty/universe i386 Packages
Hit http://nl.archive.ubuntu.com trusty/multiverse i386 Packages
Hit http://ppa.launchpad.net trusty/main Translation-en
Ign http://security.ubuntu.com trusty-security InRelease
Hit http://nl.archive.ubuntu.com trusty/main Translation-en
Hit http://ppa.launchpad.net trusty/main amd64 Packages
Hit http://nl.archive.ubuntu.com trusty/multiverse Translation-en
Hit http://ppa.launchpad.net trusty/main i386 Packages
Hit http://nl.archive.ubuntu.com trusty/restricted Translation-en
Hit http://ppa.launchpad.net trusty/main Translation-en
Hit http://nl.archive.ubuntu.com trusty/universe Translation-en
Get: 3 http://nl.archive.ubuntu.com trusty-updates/main Sources [234 kB]
Ign http://extras.ubuntu.com trusty/main Translation-en_US
Get: 4 http://nl.archive.ubuntu.com trusty-updates/restricted Sources [4725 B]
Get: 5 http://nl.archive.ubuntu.com trusty-updates/universe Sources [135 kB]
Ign http://extras.ubuntu.com trusty/main Translation-en
Get: 6 http://nl.archive.ubuntu.com trusty-updates/multiverse Sources [5143 B]
Get: 7 http://nl.archive.ubuntu.com trusty-updates/main amd64 Packages [619 kB]
Hit http://security.ubuntu.com trusty-security Release.gpg
Get: 8 http://nl.archive.ubuntu.com trusty-updates/restricted amd64 Packages [15,4 kB]
Get: 9 http://nl.archive.ubuntu.com trusty-updates/universe amd64 Packages [312 kB]
Get: 10 http://nl.archive.ubuntu.com trusty-updates/multiverse amd64 Packages [11,9 kB]
Get: 11 http://nl.archive.ubuntu.com trusty-updates/main i386 Packages [601 kB]
Hit http://security.ubuntu.com trusty-security Release
Get: 12 http://nl.archive.ubuntu.com trusty-updates/restricted i386 Packages [15,1 kB]
Get: 13 http://nl.archive.ubuntu.com trusty-updates/universe i386 Packages [313 kB]
Get: 14 http://nl.archive.ubuntu.com trusty-updates/multiverse i386 Packages [12,1 kB]
Hit http://nl.archive.ubuntu.com trusty-updates/main Translation-en
Hit http://nl.archive.ubuntu.com trusty-updates/multiverse Translation-en
Hit http://nl.archive.ubuntu.com trusty-updates/restricted Translation-en
Hit http://nl.archive.ubuntu.com trusty-updates/universe Translation-en
Hit http://nl.archive.ubuntu.com trusty-backports/main Sources
Hit http://nl.archive.ubuntu.com trusty-backports/restricted Sources
Hit http://nl.archive.ubuntu.com trusty-backports/universe Sources
Hit http://nl.archive.ubuntu.com trusty-backports/multiverse Sources
Hit http://nl.archive.ubuntu.com trusty-backports/main amd64 Packages
Hit http://nl.archive.ubuntu.com trusty-backports/restricted amd64 Packages
Hit http://nl.archive.ubuntu.com trusty-backports/universe amd64 Packages
Hit http://security.ubuntu.com trusty-security/main Sources
Hit http://nl.archive.ubuntu.com trusty-backports/multiverse amd64 Packages
Hit http://nl.archive.ubuntu.com trusty-backports/main i386 Packages
Hit http://nl.archive.ubuntu.com trusty-backports/restricted i386 Packages
Hit http://nl.archive.ubuntu.com trusty-backports/universe i386 Packages
Hit http://nl.archive.ubuntu.com trusty-backports/multiverse i386 Packages
Hit http://nl.archive.ubuntu.com trusty-backports/main Translation-en
Hit http://nl.archive.ubuntu.com trusty-backports/multiverse Translation-en
Hit http://nl.archive.ubuntu.com trusty-backports/restricted Translation-en
Hit http://nl.archive.ubuntu.com trusty-backports/universe Translation-en
Hit http://security.ubuntu.com trusty-security/restricted Sources
Ign http://nl.archive.ubuntu.com trusty/main Translation-en_US
Ign http://nl.archive.ubuntu.com trusty/multiverse Translation-en_US
Ign http://nl.archive.ubuntu.com trusty/restricted Translation-en_US
Ign http://nl.archive.ubuntu.com trusty/universe Translation-en_US
Hit http://security.ubuntu.com trusty-security/universe Sources
Hit http://security.ubuntu.com trusty-security/multiverse Sources
Hit http://security.ubuntu.com trusty-security/main amd64 Packages
Hit http://security.ubuntu.com trusty-security/restricted amd64 Packages
Hit http://security.ubuntu.com trusty-security/universe amd64 Packages
Hit http://security.ubuntu.com trusty-security/multiverse amd64 Packages
Hit http://security.ubuntu.com trusty-security/main i386 Packages
Hit http://security.ubuntu.com trusty-security/restricted i386 Packages
Hit http://security.ubuntu.com trusty-security/universe i386 Packages
Hit http://security.ubuntu.com trusty-security/multiverse i386 Packages
Hit http://security.ubuntu.com trusty-security/main Translation-en
Hit http://security.ubuntu.com trusty-security/multiverse Translation-en
Hit http://security.ubuntu.com trusty-security/restricted Translation-en
Ign http://installrepo.kaltura.org jupiter/main Translation-en_US
Hit http://security.ubuntu.com trusty-security/universe Translation-en
Ign http://installrepo.kaltura.org jupiter/main Translation-en
Fetched 2343 kB in 3s (758 kB/s)
Reading package lists…
Reading package lists…
Building dependency tree…
Reading state information…
Reading extended state information…
Initializing package states…
Writing extended state information…
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Writing extended state information…
Reading package lists…
Building dependency tree…
Reading state information…
Reading extended state information…
Initializing package states…
‘multiverse’ distribution component is already enabled for all sources.
Reading package lists…
Building dependency tree…
Reading state information…
Reading extended state information…
Initializing package states…
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Writing extended state information…
Reading package lists…
Building dependency tree…
Reading state information…
Reading extended state information…
Initializing package states…
Reading package lists…
Building dependency tree…
Reading state information…
Reading extended state information…
Initializing package states…
The following NEW packages will be installed:
kaltura-postinst
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/69,7 kB of archives. After unpacking 308 kB will be used.
Writing extended state information…
Selecting previously unselected package kaltura-postinst.
(Reading database … 302565 files and directories currently installed.)
Preparing to unpack …/kaltura-postinst_1.0.28-1+b4_all.deb …
Unpacking kaltura-postinst (1.0.28-1+b4) …
Setting up kaltura-postinst (1.0.28-1+b4) …
Reading package lists…
Building dependency tree…
Reading state information…
Reading extended state information…
Initializing package states…
Writing extended state information…
Reading package lists…
Building dependency tree…
Reading state information…
Reading extended state information…
Initializing package states…
The following NEW packages will be installed:
kaltura-base
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/81,5 MB of archives. After unpacking 202 MB will be used.
Writing extended state information…
Preconfiguring packages …
Selecting previously unselected package kaltura-base.
(Reading database … 302634 files and directories currently installed.)
Preparing to unpack …/kaltura-base_10.19.0-2_all.deb …
Unpacking kaltura-base (10.19.0-2) …
Setting up kaltura-base (10.19.0-2) …
[… Answers to configuration questions:
CDN Hostname: mydomain.eu
Apache virtual hostname: kaltura.mydomain.eu
Vhost port to listen on: 443
DB hostname: mydomain.eu
DB port: 3306
MySQL super use [only needed for install]: *******
MySQL super user passwd [only for install]: *******
Analytics DB hostname: localhost
Analytics DB port: 3306
Sphinx hostname: 127.0.0.1
Secondary Sphinx hostname: mydomain.eu
Base URL where the Kaltura API and Apps will be accessed from: https//kaltura.mydomain.eu:443
Range of ip addresses belonging to internal kaltura servers: 0.0.0.0-255.255.255.255
VOD packager hostname: 127.0.0.1
VOD packager port: 88
Kaltura Admin user (email address): myemail@mydomain.eu
Admin user login password: ****
(…)
Your Kaltura install name: Kaltura Video Platform
Auto generate MySQL kaltura password? Y

apache2: unrecognized service
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
100 492 0 0 100 492 0 1178 --:–:-- --:–:-- --:–:-- 1179
Reading package lists…
Building dependency tree…
Reading state information…
Reading extended state information…
Initializing package states…
Writing extended state information…
Reading package lists…
Building dependency tree…
Reading state information…
Reading extended state information…
Initializing package states…
The following NEW packages will be installed:
apache2{a} apache2-bin{a} apache2-data{a} apache2-mpm-prefork{a}
kaltura-clipapp{a} kaltura-html5-studio kaltura-html5lib kaltura-kclip{a}
kaltura-kcw{a} kaltura-kdp{a} kaltura-kdp3{a} kaltura-kdp3wrapper{a}
kaltura-kdpwrapper{a} kaltura-kmc{a} kaltura-krecord{a}
kaltura-kupload{a} kaltura-widgets libapache2-mod-php5{a} libapr1{a}
libaprutil1{a} libaprutil1-dbd-sqlite3{a} libaprutil1-ldap{a}
0 packages upgraded, 22 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/639 MB of archives. After unpacking 783 MB will be used.
Writing extended state information…
Selecting previously unselected package libapr1:amd64.
(Reading database … 318337 files and directories currently installed.)
Preparing to unpack …/libapr1_1.5.0-1_amd64.deb …
Unpacking libapr1:amd64 (1.5.0-1) …
Selecting previously unselected package libaprutil1:amd64.
Preparing to unpack …/libaprutil1_1.5.3-1_amd64.deb …
Unpacking libaprutil1:amd64 (1.5.3-1) …
Selecting previously unselected package libaprutil1-dbd-sqlite3:amd64.
Preparing to unpack …/libaprutil1-dbd-sqlite3_1.5.3-1_amd64.deb …
Unpacking libaprutil1-dbd-sqlite3:amd64 (1.5.3-1) …
Selecting previously unselected package libaprutil1-ldap:amd64.
Preparing to unpack …/libaprutil1-ldap_1.5.3-1_amd64.deb …
Unpacking libaprutil1-ldap:amd64 (1.5.3-1) …
Selecting previously unselected package apache2-bin.
Preparing to unpack …/apache2-bin_2.4.7-1ubuntu4.5_amd64.deb …
Unpacking apache2-bin (2.4.7-1ubuntu4.5) …
Selecting previously unselected package apache2-data.
Preparing to unpack …/apache2-data_2.4.7-1ubuntu4.5_all.deb …
Unpacking apache2-data (2.4.7-1ubuntu4.5) …
Selecting previously unselected package apache2.
Preparing to unpack …/apache2_2.4.7-1ubuntu4.5_amd64.deb …
Unpacking apache2 (2.4.7-1ubuntu4.5) …
Selecting previously unselected package apache2-mpm-prefork.
Preparing to unpack …/apache2-mpm-prefork_2.4.7-1ubuntu4.5_amd64.deb …
Unpacking apache2-mpm-prefork (2.4.7-1ubuntu4.5) …
Selecting previously unselected package libapache2-mod-php5.
Preparing to unpack …/libapache2-mod-php5_5.5.9+dfsg-1ubuntu4.11_amd64.deb …
Unpacking libapache2-mod-php5 (5.5.9+dfsg-1ubuntu4.11) …
Selecting previously unselected package kaltura-clipapp.
Preparing to unpack …/kaltura-clipapp_1.3-1+b2_all.deb …
Unpacking kaltura-clipapp (1.3-1+b2) …
Selecting previously unselected package kaltura-html5-studio.
Preparing to unpack …/kaltura-html5-studio_2.0.0-1_all.deb …
Unpacking kaltura-html5-studio (2.0.0-1) …
Selecting previously unselected package kaltura-html5lib.
Preparing to unpack …/kaltura-html5lib_2.34-1_all.deb …
Unpacking kaltura-html5lib (2.34-1) …
Selecting previously unselected package kaltura-kclip.
Preparing to unpack …/kaltura-kclip_1.1.2.1-1_all.deb …
Unpacking kaltura-kclip (1.1.2.1-1) …
Selecting previously unselected package kaltura-kcw.
Preparing to unpack …/kaltura-kcw_2.2.4-1+b3_all.deb …
Unpacking kaltura-kcw (2.2.4-1+b3) …
Selecting previously unselected package kaltura-kdp.
Preparing to unpack …/kaltura-kdp_2.7.0-1_all.deb …
Unpacking kaltura-kdp (2.7.0-1) …
Selecting previously unselected package kaltura-kdp3.
Preparing to unpack …/kaltura-kdp3_3.9.9-1+b3_amd64.deb …
Unpacking kaltura-kdp3 (3.9.9-1+b3) …
Selecting previously unselected package kaltura-kdp3wrapper.
Preparing to unpack …/kaltura-kdp3wrapper_37-1_all.deb …
Unpacking kaltura-kdp3wrapper (37-1) …
Selecting previously unselected package kaltura-kdpwrapper.
Preparing to unpack …/kaltura-kdpwrapper_11-1_all.deb …
Unpacking kaltura-kdpwrapper (11-1) …
Selecting previously unselected package kaltura-kmc.
Preparing to unpack …/kaltura-kmc_5.39.8-1+b1_all.deb …
Unpacking kaltura-kmc (5.39.8-1+b1) …
Selecting previously unselected package kaltura-krecord.
Preparing to unpack …/kaltura-krecord_1.7-1_all.deb …
Unpacking kaltura-krecord (1.7-1) …
Selecting previously unselected package kaltura-kupload.
Preparing to unpack …/kaltura-kupload_1.2.16-1_all.deb …
Unpacking kaltura-kupload (1.2.16-1) …
Selecting previously unselected package kaltura-widgets.
Preparing to unpack …/kaltura-widgets_10.9.0-1+b4_all.deb …
Unpacking kaltura-widgets (10.9.0-1+b4) …
Processing triggers for man-db (2.6.7.1-1ubuntu1) …
Processing triggers for ureadahead (0.100.0-16) …
Processing triggers for ufw (0.34~rc-0ubuntu2) …
Setting up libapr1:amd64 (1.5.0-1) …
Setting up libaprutil1:amd64 (1.5.3-1) …
Setting up libaprutil1-dbd-sqlite3:amd64 (1.5.3-1) …
Setting up libaprutil1-ldap:amd64 (1.5.3-1) …
Setting up apache2-bin (2.4.7-1ubuntu4.5) …
Setting up apache2-data (2.4.7-1ubuntu4.5) …
Setting up apache2 (2.4.7-1ubuntu4.5) …
Enabling module mpm_event.
Enabling module authz_core.
Enabling module authz_host.
Enabling module authn_core.
Enabling module auth_basic.
Enabling module access_compat.
Enabling module authn_file.
Enabling module authz_user.
Enabling module alias.
Enabling module dir.
Enabling module autoindex.
Enabling module env.
Enabling module mime.
Enabling module negotiation.
Enabling module setenvif.
Enabling module filter.
Enabling module deflate.
Enabling module status.
Enabling conf charset.
Enabling conf localized-error-pages.
Enabling conf other-vhosts-access-log.
Enabling conf security.
Enabling conf serve-cgi-bin.
Enabling site 000-default.

  • Starting web server apache2
    AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the ‘ServerName’ directive globally to suppress this message

Setting up kaltura-clipapp (1.3-1+b2) …
Setting up kaltura-html5-studio (2.0.0-1) …
Setting up kaltura-kclip (1.1.2.1-1) …
Processing triggers for ureadahead (0.100.0-16) …
Processing triggers for ufw (0.34~rc-0ubuntu2) …
Setting up apache2-mpm-prefork (2.4.7-1ubuntu4.5) …
Setting up libapache2-mod-php5 (5.5.9+dfsg-1ubuntu4.11) …
php5_invoke: Enable module readline for apache2 SAPI
php5_invoke: Enable module memcached for apache2 SAPI
php5_invoke: Enable module ldap for apache2 SAPI
php5_invoke zz-kaltura: already enabled for apache2 SAPI
php5_invoke: Enable module opcache for apache2 SAPI
php5_invoke: Enable module ssh2 for apache2 SAPI
php5_invoke: Enable module xsl for apache2 SAPI
php5_invoke: Enable module pdo_mysql for apache2 SAPI
php5_invoke: Enable module curl for apache2 SAPI
php5_invoke: Enable module mysql for apache2 SAPI
php5_invoke: Enable module gmp for apache2 SAPI
php5_invoke: Enable module gd for apache2 SAPI
php5_invoke: Enable module json for apache2 SAPI
php5_invoke: Enable module mcrypt for apache2 SAPI
php5_invoke: Enable module apcu for apache2 SAPI
php5_invoke: Enable module pdo for apache2 SAPI
php5_invoke: Enable module mysqli for apache2 SAPI
Module mpm_event disabled.
Enabling module mpm_prefork.
apache2_switch_mpm Switch to prefork

  • Restarting web server apache2
    AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the ‘ServerName’ directive globally to suppress this message
    …done.
    dpkg: error processing package libapache2-mod-php5 (–configure):
    subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of kaltura-html5lib:
    kaltura-html5lib depends on libapache2-mod-php5; however:
    Package libapache2-mod-php5 is not configured yet.

dpkg: error processing package kaltura-html5lib (–configure):
dependency problems - leaving unconfigured
Setting up kaltura-kcw (2.2.4-1+b3) …
No apport report written because the error message indicates its a followup error from a previous failure.
Setting up kaltura-kdp (2.7.0-1) …
Setting up kaltura-kdp3 (3.9.9-1+b3) …
Setting up kaltura-kdp3wrapper (37-1) …
Setting up kaltura-kdpwrapper (11-1) …
Setting up kaltura-kmc (5.39.8-1+b1) …
Setting up kaltura-krecord (1.7-1) …
Setting up kaltura-kupload (1.2.16-1) …
Setting up kaltura-widgets (10.9.0-1+b4) …
Processing triggers for libc-bin (2.19-0ubuntu6.6) …
Errors were encountered while processing:
libapache2-mod-php5
kaltura-html5lib
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up libapache2-mod-php5 (5.5.9+dfsg-1ubuntu4.11) …
php5_invoke readline: already enabled for apache2 SAPI
php5_invoke memcached: already enabled for apache2 SAPI
php5_invoke ldap: already enabled for apache2 SAPI
php5_invoke zz-kaltura: already enabled for apache2 SAPI
php5_invoke opcache: already enabled for apache2 SAPI
php5_invoke ssh2: already enabled for apache2 SAPI
php5_invoke xsl: already enabled for apache2 SAPI
php5_invoke pdo_mysql: already enabled for apache2 SAPI
php5_invoke curl: already enabled for apache2 SAPI
php5_invoke mysql: already enabled for apache2 SAPI
php5_invoke gmp: already enabled for apache2 SAPI
php5_invoke gd: already enabled for apache2 SAPI
php5_invoke json: already enabled for apache2 SAPI
php5_invoke mcrypt: already enabled for apache2 SAPI
php5_invoke apcu: already enabled for apache2 SAPI
php5_invoke pdo: already enabled for apache2 SAPI
php5_invoke mysqli: already enabled for apache2 SAPI
dpkg: error processing package libapache2-mod-php5 (–configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of kaltura-html5lib:
kaltura-html5lib depends on libapache2-mod-php5; however:
Package libapache2-mod-php5 is not configured yet.

dpkg: error processing package kaltura-html5lib (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libapache2-mod-php5
kaltura-html5lib
Reading package lists…
Building dependency tree…
Reading state information…
Reading extended state information…
Initializing package states…
Writing extended state information…

Hi Peter,

The problem starts here:
Enabling module mpm_prefork.
apache2_switch_mpm Switch to prefork

  • Restarting web server apache2
    AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the ‘ServerName’ directive globally to suppress this message
    …done.
    dpkg: error processing package libapache2-mod-php5 (–configure):
    subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of kaltura-html5lib:
    kaltura-html5lib depends on libapache2-mod-php5; however:
    Package libapache2-mod-php5 is not configured yet.

Seems the current Apache config is broken.

I suggest you check what sites are enabled for Apache, look at:
/etc/apache2/sites-enabled

if there is anything of an old Kaltura install there, for example zzzkaltura.conf, disable it with
# a2dissite zzzkaltura.conf
then make sure apache starts properly with:
# /etc/init.d/apache2 restart
purge any old install left overs, run the script again while logging everything and let me know as to the result

Dear Jess,

I saw that error about the missing server name but don’t know what to do about it: I had completely removed apache, or at least I think so, using synaptic to remove any package that had ‘apache’ in the name and doing rm -rf /etc/apache2 for good measure so there was no /etc/apache2/sites-enabled directory at all before I started the installation. Was there anything else I should have removed?

At this point, the sites-available directory has been created but it only contains the newly-installed 000-default.conf and default-ssl.conf. Only 000-default is enabled, redirecting *.80 to 127.0.0.1 document dir /var/www/html.

Should I put the global ServerName in a conf file (httpd.conf or fqdn.conf and then leave these files in place when I remove apache/kaltura & re-run the script? Or should I put it in hostname or /etc/hosts?

Currently hostname only contains the name of the computer, but not the domain (so it is something like myhostname rather than myhostname.mydomain.eu) and the /etc/hosts file contains references to myhostname, myhostname.mydomain.eu, mydomain.eu, myhostname.ouruniversity.eu and localhost, all referring to 127.0.0.1 . Should I include a line in /etc/hosts with the external host name and the external IPv4 address?

Sorry for all the questions caused by my lack of Linux knowledge, and thanks for your patience!

Best regards,

Peter

Hi Peter,

You shouldn’t need to do any Apache configurations prior to running the install script unless you have some prior configurations that might cause an issue which, from your current description of things does not seem to be the case.

its fine for the hostname to resolve to 127.0.0.1 internally but you do need to make sure your client, i.e, where you open the browser to login to the Kaltura interfaces, can resolve the service URL you input during the installation.