Cannot login to kmc after update

Hi Jess
I was posting here because I had been trying to troubleshoot why videos refused to play on mac computers. I figured the best first step was to update the software, so I ran apt-get update, then apt-get upgrade. There were numerous packages to update, and it went through without errors, but with a few warnings. The only instructions given after the updates was to restart apache which I did.

Now, I can login to the kaltura as the super admin (you have info) but as soon as I try and ‘manage’ a users account, i only get a spinning icon saying loading on the kaltura toolbar. I have tried this on win,linux,mac and it is the same problem on all comps and browsers so I doubt it is a flash problem.

When I look at the apache error log it says
authz:core error client denied by server configuration /opt/kaltura/app/kmc referrer … my site

I had intended to go into the clients media manager to see if he had deselected an encoding version that would work on mac to see if I could figure out why the player would not work on apple computers as it doesn’t seem to revert to html5 instead of flash for apple devices. I’ve read everything I can find this past month on the player before posting here and bugging someone but I’m out of ideas now that I can’t access the admin even.

Figured you might want the report anyhow as this is a totally ‘stock’ install setup and the only change was truly the apt-upgrade, so something ‘may’ have gone wrong on the kaltura update. If you are able to help and want to look - your info is the same on the server.

thanks for taking the time to read my post.


Post upgrading the packages, you need to run:

# dpkg-reconfigure kaltura-base
# dpkg-reconfigure kaltura-front
# dpkg-reconfigure kaltura-batch

As mentioned here:

I imagine this will solve all your issues but if not, let me know.

Thank you, it solved the problem of getting into the admin.
There ‘might be’ a bug in the update as I notice that now when i log into a client account and click on the ‘usage dashboard’; I now get a page not found
the requested url /apps/usage-dashboard/v0.11.2/index.html was not found on this server.

I also was trying to solve the initial problem of videos not playing on mac computers so I went into an existing video and chose another encoding format. I noticed that it is now stuck in the queue, no errors that I see, it just seems to refuse to convert the file to the added format. It’s only been about 15 mins or so, so I’ll wait a few hrs and see if it kicks to processing.

By any chance is it a known problem of videos not playing on mac/iphone when using the wordpress all-in-one plugin? I’m just grasping at straws now in trying to come up with a setup that just works across devices on wordpress.

thanks again for jumping in with the suggestions.

OK, I believe the problem with Chrome is with the Wordpress all-in-one plugin. I believe this because when I am creating a post and select a video to insert, I can indeed preview the video in the popup window. However, when the post itself is previewed or posted, the player shows up, thumbnail and all, but just spins the loading icon. I have no clue how to proceed with this. I hope that this bug report helps the dev of the plugin. Maybe he/she doesn’t have access to a mac to test playback and just assumed it works? Or of course I could be doing something wrong somehow, usually the case :slight_smile:

Hi @gaffneyiphone1,

To isolate the problem: do regular embeds, outside of WP play correctly on Mac?
If not, then it is not a WP specific issue.

At any rate, please share a test page we can look at.
It would also help if you open the browser’s dev tools and check both the “Console” and “Network” tabs for errors.