Cannot live stream using latest Kaltura CE

I am trying to test the live streaming capabilities of the latest Kaltura CE.
The list of packages I have installed on a clean setup of Ubuntu 16.04 Xenial is:

root@kaltura:/opt/kaltura/nginx/conf# dpkg -l|grep kaltura
ii  kaltura-base                        13.9.0-2+b2                                all          Kaltura Open Source Video Platform
ii  kaltura-batch                       13.9.0-1+b1                                all          Kaltura Open Source Video Platform - batch server
ii  kaltura-clipapp                     1.3-1+b2                                   all          Kaltura Video Presentations Manager
ii  kaltura-db                          12.15.0-1+b7                               all          Kaltura Open Source Video Platform - batch server
ii  kaltura-dwh                         12.14.0-1+b2                               amd64        Kaltura Open Source Video Platform - Analytics
ii  kaltura-ffmpeg                      3.2-3                                      amd64
ii  kaltura-ffmpeg-aux                  2.1.3-1                                    amd64
ii  kaltura-flexwrapper                 1.2-1+b1                                   all          Kaltura Video Presentations Manager
ii  kaltura-front                       13.9.0-1+b1                                all          Kaltura Open Source Video Platform - frontend server
ii  kaltura-html5-studio                2.1.0-1                                    all          Kaltura Open Source Video Platform - frontend server
ii  kaltura-html5lib                    2.64-1+b1                                  all          Kaltura Open Source Video Platform - HTML5 player
ii  kaltura-kclip                                               all          Kaltura Video Presentations Manager
ii  kaltura-kcw                         2.2.4-1+b6                                 all          Kalture Contribution Wizard
ii  kaltura-kdp                         2.7.0-1+b1                                 all          Kaltura Dynamic Player
ii  kaltura-kdp3                        3.9.9-1+b4                                 amd64        Kaltura Dynamic Player
ii  kaltura-kdp3wrapper                 37-1+b3                                    all          KDP3 Wrapper
ii  kaltura-kdpwrapper                  11-1+b2                                    all          KDP Wrapper
ii  kaltura-kmc                         5.43.9-1                                   all          Kaltura Management Console
ii  kaltura-krecord                     1.7-1+b1                                   all          Kaltura kRecord - used for recording from web cam
ii  kaltura-kupload                     1.2.16-1+b2                                all          Kaltura kupload widget
ii  kaltura-nginx                       1.12.2-3+b7                                amd64        Nginx web/proxy server - for Kaltura
ii  kaltura-pentaho                     4.2.1+b2                                   amd64        Pentaho Open Source Data Integration Community Edition (CE).
ii  kaltura-postinst                    1.0.33-3+b6                                all          Kaltura Open Source Video Platform
ii  kaltura-sphinx                      2.2.1-4+b3                                 amd64        Sphinx full-text search server - for Kaltura
ii  kaltura-widgets                     10.9.0-1+b7                                all          Kaltura Open Source Video Platform - widgets meta package

I set-up the live entry in the KMC with the first option for Live Streaming Type: Kaltura Live Streaming (HDS/HLS/DASH). In the Live Stream section I have the primary URL with the value: rtmp://@PRIMARY_MEDIA_SERVER_HOST@:@PRIMARY_MEDIA_SERVER_PORT@/kLive/?p=100&e=0_dosbbbjw&i=0&t=6e2124eb and the Stream Name 0_dosbbbjw_1

I configured OBS with corresponding URL and stream key:
I had to configure port 1936, as configured in the kaltura-nginx configuration.

The OBS connects and streams correctly, as the green indicator apears on the interface. However either on the entry edit form or in the preview&embed form there is no playback possible:

I also tried to stream with the stream key wihout the _1 index, but no luck.

I searched intensively the configuration files trying to figure it out if there is something wrong with the configs but nothing came up.
I checked in the admin console for permissions for the user I connect with to the KMC and enabled all settings related to live streaming.
Am I doing something wrong?

Thank you for any help.


Hi @mediasync,

When creating a live media entry, for Live Stream Type, select “Manual Live Stream URLs”, provide a meaningful name for the entry, for example “My Live Test”, and input “http://$YOUR_NGINX_HOST:$NGINX_PORT/hlsme/$DESIRED_STREAM_NAME.m3u8” in the “HLS stream URL” text box.

The “Kaltura Live Streaming” option is meant to work with Wowza, which is not FOSS.
Please see for a step by step walk-through of this solution which utilises the FOSS Nginx RTMP module.

Let me know if you have additional questions,

Thank you for the clarification. I tried the way you describe it, but the video played from the hls stream is shrinked related to the size of the player. It’s like a thick black frame around the video, even in full screen.
I would like to consider also the variant involving Wowza. Can you please point me in the right direction on how to implement Kaltura CE with Wowza?

Thank you!

I have another question. Is it possible to specify multiple stream qualities for adaptive live streaming when creating a manual live stream entry? Like for example to have 1080p and 720p HLS streams as sources for the player.

Thank you and a Happy New Year!

Hi @mediasync,

Yes, it is possible to set up adaptive bitrate using the Nginx RTMP module and ffmpeg.

You simply need to add some additional configuration to /opt/kaltura/nginx/conf/nginx.conf.

In regards to using Wowza and the media-server and livedvr repos, this solution is not officially supported when using CE and so there are no official deb packages though as you can see, the repos are FOSS and licensed under AGPLv3 so if you’d like to deploy them manually from the source, you are welcome to do so.

Like I said, you’ll also need to pay for a Wowza license. If you do decide to try, use Wowza of version 4.7.1. It’s important to state that I cannot commit to providing support for this but you are always welcome to post additional questions.

Thank you for your kind support!


Hi @jess .
this link explains how to stream from obs studio to kaltura provided by kaltura docs
is this way of streaming blocked with kaltura ce ?
note: obs will show the idicatore of streaming , and the path of /var/tmp/hlsme/ has the segments with exact name provided by the live entry hls dash, but the player dose not seem to recognize it.
dose it make a sens ?

See my reply to you here:

thanks for you anwser
I do the live streaming the way in the links show, but i want to know if i can do with the option Kaltura Live Streaming (HDS/HLS/DASH) because i want recording the live streaming but the only option appears enable is with “Kaltura Live Streaming (HDS/HLS/DASH)”.
How a way to recording in the server the live streaming with the option “Manual Live Stream URLs” ?

Please see