Can not get category, and reindex now nothing

So, decided to run the /opt/kaltura/bin/, after reading this post:

as our categories existed but were not display, when I ran the command I now get this error:

PHP Catchable fatal error: Argument 1 passed to kSphinxSearchManager::saveToSphinx() must be an instance of IIndexable, instance of CaptionAssetItem given, called in /opt/kaltura/app/deployment/base/scripts/populateSphinxCaptionAssetItem.php on line 33 and defined in /opt/kaltura/app/plugins/search/providers/sphinx_search/lib/kSphinxSearchManager.php on line 532
Failed to run /opt/kaltura/app/deployment/base/scripts/populateSphinxCaptionAssetItem.php.
Please try to run it manually and look at the logs

and now in my Kaltura interface there are no video entries?

I went ahead and modified the code as described here:

@trevor_c thank you so much for providing it, replacing also fixed our issues and the reindex complete. I will see what is the best course of next action is with regard to the file.

So here is a new twist, and it could probably be related since the indexing we messed with was CaptionAssetItem, but now all of our players work fine, but neither of the players with captions will play a video, they just keep spinning. I have placed the code back in and get the same result. Going to look at some log files to see if I can tell what the issue is.

Hello @bkelm,

Are you able to obtain the captions via the API (or see them in KMC which also uses the API to fetch them)?

Also, is your Elasticsearch daemon running?