Bulk upload + s3 storage profile is re-transcoding flavours specified in xml


#1

Hiya

Me again. At the moment I am testing bulk uploads and importing pre transcoded flavours.

Everything works just fine to a point, the source and the flavours are ingested from remote url’s with no problem. They are validated then exported and all get a status of OK. Then in top I notice ffmpeg pop up and in the flavours section of kmcng all the flavours that have just uploaded start transcoding.

In the batch process entry investigator, I can see that my source and 3 pre-encoded files all arrive OK, however, once the source is finished uploading it transcodes the flavours again.

Is there a way to stop this from happening? My remote storage profile is automatic, flavour ready->required


#2

Hello @michael_hall,

I believe this is what you’re looking for: https://github.com/kaltura/server/blob/Naos-14.16.0/plugins/bulk_upload/xml/xml/ingestion.xsd#L1054

Cheers,


#3

Hi @jess thanks for the prompt response

Yes that’s the example I was using for my test xml

<?xml version="1.0" encoding="UTF-8"?>
<mrss version="1.0">
  <channel>
    <item>
      <action>add</action>
      <referenceId>xxxx</referenceId>
      <type>1</type>
      <userId>michael@xxx.com</userId>
      <name>some name</name>
      <conversionProfileId>10</conversionProfileId>
      <media>
        <mediaType>1</mediaType>
      </media>
      <contentAssets>
        <content flavorParamsId="0">
          <urlContentResource url="https://example.com/video0.mp4"></urlContentResource>
        </content>
        <content flavorParamsId="2">
          <urlContentResource url="https://example.com/video1.mp4"></urlContentResource>
        </content>
        <content flavorParamsId="4">
          <urlContentResource url="https://example.com/video2.mp4"></urlContentResource>
        </content>
        <content flavorParamsId="5">
          <urlContentResource url="https://example.com/video3.mp4"></urlContentResource>
        </content>
      </contentAssets>
      <thumbnails>
        <thumbnail isDefault="true">
          <urlContentResource url="http://example.com/thumb.jpg"></urlContentResource>
        </thumbnail>
      </thumbnails>
    </item>
  </channel>
</mrss>

#4

Hi @jess

Curiously if I remove the source file flavorParam 0 from my xml it works fine and doesn’t transcode all the flavors again. The selected flavors get pushed to s3 and thats the end of it. However it would leave us having to store our sources seperately after the migration.


#5

Hi @michael_hall,

You can set conversionProfile to a custom profile you configure. I believe that will address your requirement.


#6

Hiya

Thanks for leading me in the right direction. I ended up creating a flavor that is basically a copy of “source” and enabled this in the transcoding profile I am using for my bulk imports. I switched off source in the same profile and my source file now points to my “legacy source” flavor in my xml.

Hopefully this will help anyone else in the same situation.

Thanks again.