Analytics issue


I have a kaltura server install (ver 9.18)
Analytic seems to be running fine and all reports are functioning.

However when I run the Top Content report and do a drill down on any of the entries I see only 0’s.
What might cause that?


Hi Ofer,

I suggest you check the logs under /opt/kaltura/dwh/logs for errors and also, while making the request, check the kaltura_api_v3.log, we can advance further once you find the relevant errors.

Hi Jess,

I didn’t see any errors (not on the dwh, and not via kaltlog while making the request).
I’ll check that again, beginning of next week.
In which table is this data supposed to be?


Hi Jess,
Any idea what might be wrong (as said I don’t see any errors), or what should I look for? *like db table names

Hi Ofer,

I don’t know but will try to find out and get back to you.

Hello, I have the same issue

0 data

and no errors in dwh logs

Hi Ofer,
Do you use some filter on the Top Content report?
Can you please send a saz file so I can see the report type and filter?

Hi @orly_lampert
You can get the saz file from this link:

Hi Ofer,
I get 404 error when trying to access this page

Sorry my mistake:

Can you please check if this partner have the “End - User Reports” feature enabled?

Yes this feature is enabled.

can you please run this query om kalturadw db (replace partner_id param)
SELECT * FROM kalturadw.dwh_dim_permissions WHERE partner_id = <partner_id> AND NAME = ‘FEATURE_END_USER_REPORTS’ AND STATUS = 1

I’m running on ver 9.18 and the kalturadw.dwh_dim_permissions table is empty

I just updated to the new version of kaltura
and the pentaho has an update too

it seems to be a problem with the pentaho
solved in the recent update-


Why don’t you upgrade to latest?
It should be pretty straight forward to do and there are a lot of other fixes and features you’ll be gaining.

The client has a stable environment and doesn’t want to upgrade.
Can you point me to whats need to be done/taken from a more advanced version?

@orly_lampert, can I copy the content of the table from ver 10.18 to 9.18?