All entries gone

Suddenly all entries is gone from both playlists and KMC. They do show up in Select id, name, status from entry where status = 2 . Same for category, playlists and tags. Uploading a new clip do show up in KMC though.

Where do I start looking?

Hi @arnebajse,

See my reply here:

Bottom line: make sure the kaltura-sphinx daemon is running [I imagine it is since you say new entries do show], if you’re working on a clustered ENV, make sure the kaltura-populate daemon is also running and then try to reindex all Sphinx nodes with:
# /opt/kaltura/bin/


After a restart of kaltura-sphinx everything was back on track. It did show two errors though.
WARNING: index ‘kaltura_base’: no fields configured (use rt_field directive) - NOT SERVING
WARNING: index ‘kaltura_base_gt_in_charset’: no fields configured (use rt_field directive) - NOT SERVING

Thanks for your quick reply.

Hi @arnebajse,

Glad we’re good:)
These are just warnings, you can disregard them.

Ok thanks, I tried

sudo /opt/kaltura/bin/

It gives me an error

Failed to run /opt/kaltura/app/deployment/base/scripts/populateSphinxEntries.php.
        Please try to run it manually and look at the logs

I ran above file with command

cd /opt/kaltura/app/deployment/base/scripts/
sudo php populateSphinxEntries.php

and it gives me this error

2017-09-14 08:02:43 [BasePeer::doSelect] ERR: exception 'Exception' with message 'SQLSTATE[42S22]: Column not found: 1054 Unknown column 'category_entry.CREATOR_KUSER_ID' in 'field list'' in /opt/kaltura/app/infra/log/KalturaLog.php:83
Stack trace:
#0 /opt/kaltura/app/vendor/propel/Propel.php(408): KalturaLog::err('SQLSTATE[42S22]...')
#1 /opt/kaltura/app/vendor/propel/util/BasePeer.php(466): Propel::log('SQLSTATE[42S22]...', 3)
#2 /opt/kaltura/app/alpha/lib/model/om/BasecategoryEntryPeer.php(365): BasePeer::doSelect(Object(Criteria), Object(KalturaPDO))
#3 /opt/kaltura/app/alpha/lib/model/categoryEntryPeer.php(44): BasecategoryEntryPeer::doSelect(Object(Criteria), NULL)
#4 /opt/kaltura/app/alpha/lib/model/categoryEntryPeer.php(165): categoryEntryPeer::doSelect(Object(Criteria))
#5 /opt/kaltura/app/alpha/lib/model/entry.php(3053): categoryEntryPeer::selectByEntryId('_KMCSPL1')
#6 /opt/kaltura/app/plugins/search/providers/sphinx_search/lib/kSphinxSearchManager.php(220): entry->getCategoriesEntryIds()
#7 /opt/kaltura/app/plugins/search/providers/sphinx_search/lib/kSphinxSearchManager.php(527): kSphinxSearchManager->getSphinxSaveSql(Object(entry), true, false)
#8 /opt/kaltura/app/deployment/base/scripts/populateSphinxEntries.php(33): kSphinxSearchManager->saveToSphinx(Object(entry), true)
#9 {main}
2017-09-14 08:02:43 [global] ERR: exception 'Exception' with message ' [wrapped: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'category_entry.CREATOR_KUSER_ID' in 'field list']' in /opt/kaltura/app/infra/log/KalturaLog.php:83
Stack trace:
#0 /opt/kaltura/app/deployment/base/scripts/populateSphinxEntries.php(36): KalturaLog::err(' [wrapped: SQLS...')
#1 {main}

So what should I do next ?

Something has gone wrong with your upgrade.

While upgrading the RPMs, did you get any errors?
The %post phase of kaltura-base, among other things, calls:

php /opt/kaltura/app/deployment/updates/update.php -i -d >> /opt/kaltura/log/kalt_up.log 2>&1
php /opt/kaltura/app/deployment/updates/update.php -i -s >> /opt/kaltura/log/kalt_up.log 2>&1
php /opt/kaltura/app/deployment/base/scripts/installPlugins.php >> /opt/kaltura/log/kalt_up.log 2>&1

The errors you posted indicate that update.php either failed or did not run at all.
Do you see errors in /opt/kaltura/log/kalt_up.log?

Waooo It works.

Yeh man you are correct, we had internet issue when we were upgrading, this may be caused the issue.

Anyway, Its works really fine and thanks for your quick response and help.

You’re welcome, @jahanzaib_shahid.