Add SSL after install


I just successfully installed 9.19.8 on a new server - a MUCH BETTER experience than when I installed 6.x a couple years ago :slight_smile: Thank You!

I realized after the install that I had forgotten to install my ssl certs to the bare box before installing kaltura. For the life of me, I cannot figure out how to install my ssl certs now. I have placed them on the server. I have tried rerunning config base, config front, and even nuked everything and started fresh, but I cannot get the prompt “Is your Apache working with SSL?[Y/n]”

I have checked /etc/kaltura.d/system.ini and there was nothing in there. I added IS_SSL=Y just in case, but that didn’t help.

Can anyone point me in a direction to get started? Should I ignore the kaltura stuff and install the ssl certs as if it was a plain old webserver first, then run the kaltura config scripts again?



Happy to hear the experience is better:)
Please edit /etc/kaltura.d/system.ini and remove the entries for:

Then, re-run

Should be good.


Hi Jess,

I was away for a while and am finally get back to work on this now. I have looked and there is no line IS_SSL=N in /etc/kaltura.d/system.ini. I’ve also tried adding IS_SSL=Y to that file. In either case, when I run, I am presented with “It is recommended that you do work using HTTPs. Would you like to continue anyway?[N/y]”. Choosing N exits the script. Choosing yes will run me through the script but with no SSL options.

SSL is working on the server. There is an ssl.conf file in /etc/httpd/conf.d which loads my certificate and points the virtual host to the default apache root. Non-ssl traffic is properly routed to the kaltura root.

Should I remove the apache installed ssl.conf file? Should I re-run “/opt/kaltura/bin/”. Any suggestions are welcome :smile: