Access denied for user root in a docker fresh installation

I followed
When I run
docker exec -i -t kaltura /root/install/
It ask me for root user, I let de default and then it asks me a root password only for installation, I entered root because I do not know what to set.
Then I got the error
Checking MySQL version.. ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

I guess that the kaltura docker is embedding the mysql server but I do not know its root password!

1 Like


The documentation needs a bit of revising [will get to it in a moment], you should run:
# docker exec -i -t kaltura /root/install/ your_mysql_root_desired_passwd

or else, you can follow:

if you edit the template, pre-set all needed params and copy the file onto container:/root/install/config.ans , you will not be prompted for anything interactively.

1 Like

Thank you. The problem is solved.
I have another problem at the end :
base-config completed successfully, if you ever want to re-configure your system (e.g. change DB hostname) run the following script:
# rm /opt/kaltura/app/base-config.lock
# /opt/kaltura/bin/

ERROR: could not retreive partner.admin_secret for id -1. It probably means you did not yet run /opt/kaltura/app/ yet. Please do.
ERROR: /opt/kaltura/bin/ failed:( You can re-run it when the issue is fixed.
1 Like


This means something went wrong during the DB deployment phase. I suggest you drop the existing DB by calling:
# /opt/kaltura/bin/
and then rerun the install script. If something fails, it should be outputted in RED onto STDOUT/STDERR.
Please then post the full output here so I can help you further.


Thanks so this is what I’ve done :
docker exec -i -t kaltura /opt/kaltura/bin/

All right… did you re-run docker exec -i -t kaltura /opt/kaltura/bin/ afterwards? are we OK now?

Yes but the problem was not coming from that.
The problem was the URL that I’ve set to access to the service. The URL is used during the installation process (it seems).